Power Automate Issue – Resource not found for the segment ‘xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx’.

Introduction
Hi Everyone,

Welcome to the Power Guide Mentorship Program. Today I am going to share a very important PowerGuideTip18 to all the developers related to the Power Automate and CDS.
I have seen many folks have posted an issue on the community regarding the Power Automate issue while creating/updating records in CDS (Common Data Service).
Issue: 
Resource not found for the segment ‘xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx’.
Issue Description: 
As per the error description, the resource (which means the record with GUID is – ‘xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx’) could not be found in CDS.

Root Cause: 
The issue is due to the lookup field, whose value has not been set correctly.
Solution:
When you use the Common Data Service (current environment) connector in order to create/update records in Dynamics 365/CDS.
To populate a look up field, we need to specify the plural name of the entity and then the record GUID.
For Example – You are creating a Contact record in Dynamics 365 using Common Data Service (current environment) connector. For that, if you want to set the value in the Account Lookup field then your syntax must be as follow:
account/<account guid>

For Example – account/67234568-6543-7867-9878-345647898456
Now, this account GUID can be set dynamically as below:
You can get the Plural Name of any entity as follows:

Hope it helps.
- Advertisement -

LEAVE A REPLY

Please enter your comment!
Please enter your name here

- Advertisement -

Latest News

Join Us! Power BI Dev Camp! Thursday 28 January, 2021

Learn how to get started designing and implementing custom visuals for Power BI. Attendees will learn how to define...
- Advertisement -

More Articles Like This

- Advertisement -