The issue from this blog was fixed with the pac version 1.19.4. 🙂

Since a few versions, the Power Platform CLI (pac) has an issue with “pac pcf push”: the component doesn’t seem to get updated inside your environment. I’ve encountered that a while ago, when I was working on the Power Apps Grid customizer PCFs. I’ve supposed caching issues with the Power Apps Grid, and tried for hours to work arroud that, until I’ve realized that the “pac pcf push” doesn’t publish anymore.

The last version where the “pac pcf push” worked propely was v 1.16.6. Notice that it showed a “Publish All” step (red part on the screenshot below):

The versions comming after that, just doesn’t publish anymore:

The “PublishAll” logs are not listed here (should be in the red placeholder below):

The “pac pcf push” doesn’t show any errors, and it uploads very fast. But you don’t see any change inside the environment, not even inside the SolutionsLayers, not even if you increment the version

The workarround

The easiest way to work arround that is to call a publish command after that. The “pac” cli is a powerful tool after all 🙂

pac pcf push -pp 
pac solution publish

Of course the “Publish All” inside the maker portal would work too.


I’ve opened a gitHub issue. Hopefully this will be fixed soon. But until then, since you know what happens under the hood and how to work arround that, you are not blocked.

I’ll update this blog as soon I see this fixed.

Photo from Pexels by Tim Gouw